DragonflyCMS Projects > Storez > [solved] Currency in (NOK) > Community Forums > Phoenix Netology
Forum Index > eCommerce > Storez

[solved] Currency in (NOK) Reply to topic


Working Dragonfly 9.3.3.1 and Storez 9.6.1
Add norwegian.php to modul/Storez/!10 but that did not work very well. So how can I now add "NOK" as currency. Now it's just blank.

Storez work very well up to this point.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Dragonfly 9.4.0.0 cvs + Storez 9.6.2


If you had a previous installation, for language to work, you will need to remove the original language/norwegian/storez.php file.

To add a currency:
admin.php?op=Storez&mode=CartCurrencyList
then click the "Add Currency" link
then provide Currency Code and Currency Name - initially add 1.0 for the Relative Value.

Relative Value will vary according to what you have set as your default currency.

Then you need to click Update for the currency conversion - I find it may take a couple of clicks for that to work and eventually they display correctly.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Phoenix wrote
original language/norwegian/storez.php file

No such file.


Phoenix wrote
To add a currency:
admin.php?op=Storez&mode=CartCurrencyList
then click the "Add Currency" link
then provide Currency Code and Currency Name - initially add 1.0 for the Relative Value


Did so. Currency Code and Name looks ok and Value=1

Phoenix wrote
Then you need to click Update for the currency conversion - I find it may take a couple of clicks for that to work and eventually they display correctly.


No no no No no no No no no Currency Code is still blank in Storez/stores
Can I put "NOK " on manualy ??

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Dragonfly 9.4.0.0 cvs + Storez 9.6.2


Smile I'm on to translate the english version of english.php into norwegian.php and it works ok. (Except for three Nordic (spesial) letters. Can I fix it with some "define"-codes in the php-file? (Some AscII-codes perhaps) ?

About currency "[NOK] Norske kroner". Default currency ok - But the Stroez/stores has no "NOK" before the cost (blank). Can I fix that in some *.php file Confused

Smile Else Storez works fine.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Dragonfly 9.4.0.0 cvs + Storez 9.6.2


Since DF processes utf-8 you can use special characters in your language file.
e.g. å ø

Just make sure you use some utf-8 compatible editor - not MS notepad or MS wordpad but something like notepad++ and set to UTF8 without BOM.

Please provide a page link example for where NOK doesn't show. I cannot guess where your problem is - lack of display may actually be normal.

DonationsPro for vBulletin, SMF, MyBB, DragonflyCMS

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Embarassed Currency problem solved - a miss in Output. Sorry.

Smile Thanks. Notpad++ 6.1.6 is now in use.
Since I'm a vy old programer I'm not familiar with php-programs. Can you just give me just one line example - please?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Dragonfly 9.4.0.0 cvs + Storez 9.6.2


With language file, just copy english.php as norwegian.php and replace the english words with norwegian translations.

If you find missing defines, just let me know where and I will update Storez code and the language file defines and provide the files.

DonationsPro for vBulletin, SMF, MyBB, DragonflyCMS

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


copy english.php as norwegian.php and replace the english words with norwegian translations.

Yes - that is what I'm doing and it works fine - except for the 3 special letters in my norwegian language.
You have right - this does not happend in DF processes, only in Storez.

Since DF processes utf-8 you can use special characters in your language file. e.g. å ø

So - I'm sorry - this is not a true conclution. I recive cryptic symbols insted. Any solutions?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Dragonfly 9.4.0.0 cvs + Storez 9.6.2


I am not having a problem with special chars.

When you use notepad++ make sure you have:
Encoding => Encode in UTF-8 without BOM

Use special chars and save - should display special chars correctly.

You can also set this in:
Settings=>Preferences=>New Document/Default Directory
set UTF-8 without BOM - also check "Apply to opened ANSI files"

DonationsPro for vBulletin, SMF, MyBB, DragonflyCMS

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Very Happy Supurb help.
Now it works fine. Thank you very much.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Dragonfly 9.4.0.0 cvs + Storez 9.6.2

All times are Australia/Adelaide


Jump to: