DragonflyCMS Projects > Storez > [solved] Storez upgrade to 9.5.0 SQL error > Community Forums > Phoenix Netology
Forum Index > eCommerce > Storez

[solved] Storez upgrade to 9.5.0 SQL error Reply to topic


Upgrading from 9.4.1

CMS Warning line 75: On /admin.php?op=modules&upgrade=21 While executing query "ALTER TABLE cms_cart_brands CHANGE creation_date creation_date DATETIME NOT NULL DEFAULT ''" the following error occured: Invalid default value for 'creation_date' In: /****/****/public_html/includes/classes/installer.php on line: 115

Also the similar UPDATE commands which precede these did action either.

I manually updated date values in phpMyAdmin as workaround, but reporting for benefit of others.

MySQL 5.0.92-community-log (client: 5.0.92) PHP 5.3.8 DF 9.2.1

Initiated by Bugger (Original Entry) - Comments Here Please.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.2.8/5.1.73/5.4.21/9.4.0


I tested this upgrade originally, and again now - same result, no problem.

The default value 1000-01-01 00:00:00 is correct, especially so for strict compliance.

MySQL 5.0.92

dev.mysql.com/doc/refm...etime.html

DonationsPro for vBulletin, SMF, MyBB, DragonflyCMS

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Update your DF version - 9.2.1 is three years out of date.

You won't have issues with v9.3.2.

DonationsPro for vBulletin, SMF, MyBB, DragonflyCMS

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):

All times are Australia/Adelaide


Jump to: