DragonflyCMS Projects > BlogsPlus > [solved] Blogs 9.18 & Forums Pro > Community Forums > Phoenix Netology
Forum Index > Community > BlogsPlus

[solved] Blogs 9.18 & Forums Pro Reply to topic

the file:

on line calls to inexistent function called forumspro_message_prepare on line 235:

$message = empty($blog_conf['forum_type']) ? Fix_Quotes(message_prepare($message, $html_on, $bbcode_on)) : Fix_Quotes(forumspro_message_prepare($message, $html_on, $bbcode_on));

The function is called is called: message_prepare

Not sure if this is a BUG since im not using the lastest version of Forums Pro ( wich i don't know wheres avaible to download) and is that was a FIX made to avoid calling a previous declared function on the CPG-BB forums.

After Fixing this, Blogs works fine.Thanks-

Initiated by Bugger (Original Entry) - Comments Here Please.


Please enter your server specs in your user profile! 😢

Not a bug - v9.1.8 allows you to interact with ForumsPro and this is done by first setting the Forum Type, then setting the Forum Module Name.

$blog_conf['forum_type'] is empty (zero)
THEN (we are using CPG-BB)
Fix_Quotes(message_prepare($message, $html_on, $bbcode_on))
ELSE (we are using ForumsPro)
Fix_Quotes(forumspro_message_prepare($message, $html_on, $bbcode_on))

Function forumspro_message_prepare() exists in "includes/fpbbcode.php" and that file is loaded whenever $blog_conf['forum_type'] is set greater than zero i.e. ForumsPro. That function exists in ForumsPro

So, what Forum Type do you have selected in Blogs admin? Sounds like you have CPG-BB selected?

I removed ForumsPro v2.0.3 from downloads when Rayvenhaus said he was reviving myndworx Confused

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):

Thanks Phoenix, the problem was caused by a modified file of my Forum.
I've tested Blogs with a clen install and works Great.


Please enter your server specs in your user profile! 😢

All times are Australia/Adelaide

Jump to: